
 

 

 
  

TUTORIEL D’ANALYSE D’IMAGES 
 
Dans ce document vous allez apprendre comment faire une analyse 
d’image sur le logiciel ImageJ et obtenir des données pour l’analyse par 
machine learning qui sera faite par la suite. 
 
 
 
Document mis à jour le 16 juillet 2022 
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Télécharger ImageJ 
 
Téléchargez ImageJ ici  https://imagej.nih.gov/ij/download.html  
 

 
 
Choisissez la version appropriée selon votre système d’exploitation. Exemple pour un mac 
vous pouvez choisir Mac OS X, pour un PC Windows. (Si vous utilisez Linux vous n’avez pas 
besoin de précision J ) 
 
Installez le logiciel.  
 
L’icône du logiciel est un microscope.  
 
Lancez le logiciel et vous verrez apparaître cette barre d’outils : 
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Ouvrir un fichier 
 
Ouvrez une image : File -> Open  
 

 
 
Sélectionnez le dossier où se trouve les photos et cliquez sur la première photo 
ConJ1ExB1.jpg (Contrôle, jour 1, Exploration, B1) 
Cliquez sur Open  
 
 

 
 

Définir l’échelle 
 
Zoomez sur l’image (appuyez sur la touche « + » de votre clavier) afin que la règle (double 
décimètre ou autre) apparaisse plus grande. Vous pouvez vous déplacer dans l’image en 
utilisant la « main » dans la barre d’outils. 
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Pour  définir l’échelle de votre image il vous faut tracer une droite avec l’outil ligne dans la 
barre d’outils (indiqué par la flèche rouge ci-dessous). Idéalement, il vous faut tracer la ligne 
directement sur le double décimètre, si vous l’avez oublié, tracez le diamètre de votre boite 
de pétri qui est une distance connue. 
 
 

 
 
Pour tracer la ligne, cliquez sur l’image et maintenez appuyé jusqu’à atteindre la distance 
souhaitée (ici 5cm sur la photo). 
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Une fois la ligne tracée allez sur : Analyse -> Set Scale  
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Vous allez voir une fenêtre s’ouvrir  
 

 
 
Vous devez entrer la distance réelle (Known distance), ici 5cm (cela peut être n’importe 
quelle distance), et l’unité dans laquelle cette distance est indiquée (unit of length), ici cm 
(ne mettez pas autre chose que cm afin d’uniformiser les données récoltées). Cliquez 
sur OK  
 
 

 
 
Si jamais vous n’avez pas mis de double décimètre, pas de panique, utilisez-le 
diamètre de la boite et reportez sa distance en centimètre dans « Known distance ».  
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Mesurer les paramètres 
 
Allez sur :  Analyse -> Set Measurements 
 

 
 
Une fenêtre s’ouvre, vous offrant de nombreuses options, sélectionnez l’option « area » 
(aire), l’option « perimeter » (périmètre), l’option « shape descriptors » (descripteur de 
forme) et « display label » (indiquer le nom de l’image), enlevez toutes les autres options 
présélectionnées et cliquez sur OK.  
 

 
 
Une fois que vous avez défini les paramètres que vous souhaitez mesurer il faut indiquer au 
logiciel où est le blob. Deux solutions pour cela. 
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Dessinez à la main  
 
Tout d’abord, déplacez-vous dans l’image en utilisant la « main » dans le menu  afin que le 
blob apparaisse au centre de l’image 
 

 
 
Dessinez le blob à la main (lorsque vos images sont mal contrastées ou floues).  
Pour cela sélectionnez l’outil « freehand selection » (voir flèche rouge ci-dessous) et 
dessinez à main levée le contour du blob. Utiliser la souris, le touchpad ou un stylet. Cliquez 
et maintenez appuyé  tout au long du contour. 
 
 

 
 
Si vous n’êtes pas satisfait de la forme dessinée, vous pouvez ajouter des contours pour 
cela maintenez la touche shift (maj pour Mac) appuyée et ajoutez des contours en cliquant 
sur la souris (maintenez le clic). Pour retirer des contours, maintenez la touche Alt appuyée 
et rogner les contours en cliquant sur la souris (maintenez le clic) 
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Si vous ne maintenez pas le clic appuyé et que le contour disparaît, pas de panique 
Allez sur Edit-> Selection -> Restore selection.  
 

 
 
Une fois le contour terminé, appuyez sur la touche M de votre clavier, vous allez voir une 
fenêtre apparaître qui va vous donner les paramètres recherchés.  
 

 
 
Si vous faites une erreur et appuyez sur M par inadvertance, vous pouvez supprimer une 
ligne. Pour cela cliquez sur la ligne en question et appuyez sur « suppr » ou « delte » sur 
votre ordinateur. 
 
 
Une fois que vous avez appuyé sur M, ne cliquez pas sur l’image pour ne pas supprimer 
le contour que vous avez dessiné.  
 
Si cela arrive, pas de panique ! (voir section précédente).  
Allez sur Edit-> Selection -> Restore selection.  
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Pour info, les paramètres de morphologie donnés par image J sont : 
 

- L’aire : la surface couverte par le blob, quand le blob explore il s’étire et son aire augmente 
  

- Le périmètre : la longueur du contour du blob, lorsque le blob forme des pseudopodes son 
périmètre augmente. 
 

- La Circularité : Une valeur de 1 indiquant un cercle parfait. Lorsque la valeur s'approche de 0 
elle indique une forme non circulaire.  Formule 4π × [Aire] / [Périmètre]2 

 
- Le AR ratio Ellipse : Le ratio entre l'axe le plus grand et l'axe le plus petit d'une ellipse qui 

contiendrait le blob (voir figure ci-dessous). Formule : [Axe le plus grand] /[Axe le plus 
petit]. Lorsque le rapport est de 1 le blob peut être contenu dans un cercle (mais cela ne 
veut pas dire qu’il est circulaire !). Lorsqu’il est supérieur à 1 cela indique que le blob est de 
forme allongée. 

 
- La rondeur : 4 x aire/ (π x Axe le plus grand2), ou l'inverse du AR ratio Ellipse. 

 
- La solidité : Rapport de l’aire du blob sur l’aire de son enveloppe convexe. L’enveloppe 

convexe du blob correspond au plus petit domaine convexe contenant entièrement le blob, 
formule : [Aire du blob] / [Aire Convexe] (aire du blob en jaune / aire convexe en vert).  Cet 
indice s’il est proche de la valeur 1 nous indique que le blob est compact et s’il est proche de 
0 cela indique un blob extrêmement digité 

 

 
  

Aire du blob Périmètre du blob

Aire convexe
Plus grand axe de l’ellipse
Plus petit axe de l’ellipse

Aire du blob
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Baguette magique 
 
Si vous avez des images bien contrastées et de bonne qualité, vous pouvez utiliser l’outil 
baguette magique (indiqué par la flèche rouge ci-dessous). 
 
 

 
 
Cliquez sur le blob, vous allez voir que le blob n’est pas sélectionné, on voit juste un point 
jaune (indiqué par la flèche rouge ci-dessous) 
 

 
Il vous faut alors modifier la sensibilité de la baguette. Pour cela double-cliquez sur l’outil 
baguette et vous allez voir une fenêtre apparaitre qui vous permettra de modifier la 
sensibilité de la baguette (« Tolerance »). Faites bouger la barre grise (indiquée par la flèche 
rouge ci-dessous) 
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En modifiant la « tolerance » vous constaterez que l’outil sera parfois capable de délimiter le 
blob entièrement.  
 

 
 
Une fois que vous avez délimité le blob appuyez sur M, ne cliquez pas sur l’image pour ne 
pas supprimer le contour que vous avez dessiné.  
Si cela arrive, pas de panique ! 
Allez sur Edit-> Selection -> Restore sélection (voir section précédente).  
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Données pour le Machine Learning 
 
Les mesures enregistrées précédemment vont nous aider à avoir des premiers résultats. 
Toutefois, analyser toutes les données ainsi est un travail de titan. C’est pourquoi nous 
allons aussi faire appel au machine learning. Mais pour cela nous avons besoin d’analyser 
un certain nombre d’images à la main. 
 
Le Machine Learning ou apprentissage automatique consiste à laisser des algorithmes 
découvrir des ” patterns “, à savoir des motifs récurrents, dans des ensembles de données. 
Ces données peuvent être des chiffres, des mots, des images, des statistiques… Ici on 
souhaite que les algorithmes reconnaissent automatiquement le blob dans une image. 
Pour entrainer les algorithmes de Machine Learning on a besoin d’indiquer à la machine où 
est le blob sur une série d’images.  Les algorithmes de Machine Learning apprennent de 
manière autonome à effectuer une tâche (ici reconnaître un blob sur une image) et à réaliser 
des prédictions à partir de données entrées par l’utilisateur et améliorent leurs performances 
au fil du temps. Une fois entraîné, l’algorithme pourra retrouver les blobs dans des images 
nouvelles. Les données que l’on doit donner aux algorithmes sont la position des blobs et de 
la boite de pétri sur l’image. Pour cela on génère des masques et on enregistre les 
coordonnées des blobs et des boites de pétri.  
 

Enregistrer le « masque » 
 
A partir du contour du blob que vous avez dessiné on va créer un masque. 
Allez sur : Edit -> Selection -> Create Mask 
 

 
Une nouvelle image en noir et blanc apparaît  
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Enregistrez cette image au format PNG dans le dossier d’origine 
File -> Save as -> PNG 
 

 
 
Appelez le masque ConJ1ExB1_Mask.png 
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Une fois que le masque est sauvegardé fermer le fichier masque (l’image en noir et blanc), 
ne cliquez pas sur l’image originale (la photo) pour ne pas supprimer le contour que 
vous avez dessiné.  
 
Si cela arrive, pas de panique ! 
Allez sur Edit-> Selection -> Restore sélection (voir section précédente).  
 

Coordonnées X Y  du blob  
 
Un fois le masque créé on va enregistrer les coordonnées spatiales du blob. Pour cela, vous 
allez retirer l’échelle car il nous faut les coordonnées en pixel (tous les participants n’auront 
pas des images de même échelle). 
 
Allez sur : Analyse -> Set Scale  
 

 
Cliquez sur « Click to remove scale » (retirer l’échelle) et  
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Vous devez voir apparaître la fenêtre avec known distance = 0 et unit of length = pixel 
 

  
 
Allez sur : File -> Save As -> XY Coordinates 
 

 
 
Sauvegardez le fichier dans le dossier d’origine, sous le nom 
ConJ1ExB1_Coord_Blob.txt 
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Coordonnées X Y  de la boite 
 
Sélectionnez maintenant l’outil  “oval”  
 

 
 
Tracez le contour de la boite, pour cela cliquez sur le bord de la boite 
et tout en restant appuyé sur le cercle étendez la sélection. Pour 
ajuster la taille du cercle à la taille de la boite cliquez sur les petits 
carrés blancs autour du cercle. Faites de multiple ajustements jusqu’à 
ce que le cercle adopte parfaitement le contour de la boite.  
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Allez sur : File -> Save As -> XY Coordinates 
 
 

 
 
Sauvegardez le fichier dans le dossier d’origine, écrire le nom 
ConJ1ExB1_Coord_Boite.txt 
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Image suivante 
 
Une fois le masque et les coordonnées du blob et de la boite sauvegardés, fermez le fichier 
image ConJ1ExB1.jpg (ne sauvegarder pas les changements sur l’image), ne fermez par le 
tableau « results ». Ouvrez à l’image suivante ConJ1ExB2.jpg et faites à nouveau toutes ces 
opérations.   
 

Sauvegarder les données 
 
Quand vous avez terminé les 8 images de l’expérience exploration du Jour 1 
Sauvegardez le tableau de résultats 
 

 
 
Cliquez sur le tableau et Allez sur File -> Save As 
 
Nommez le tableau Results_ConJ1Ex.csv (Groupe Contrôle, Jour 1, Expérience 
Exploration) 
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Donc pour le jour 1 vous devriez avoir les fichiers : 
 
ConJ1ExB1_Mask.png 
ConJ1ExB1_Coord_Blob.txt 
ConJ1ExB1_Coord_Boite.txt 
ConJ1ExB2_Mask.png 
ConJ1ExB2_Coord_Blob.txt 
ConJ1ExB2_Coord_Boite.txt 
ConJ1ExB3_Mask.png 
ConJ1ExB3_Coord_Blob.txt 
ConJ1ExB3_Coord_Boite.txt 
ConJ1ExB4_Mask.png 
ConJ1ExB4_Coord_Blob.txt 
ConJ1ExB4_Coord_Boite.txt 
ConJ1ExB5_Mask.png 
ConJ1ExB5_Coord_Blob.txt 
ConJ1ExB5_Coord_Boite.txt 
ConJ1ExB6_Mask.png 
ConJ1ExB6_Coord_Blob.txt 
ConJ1ExB6_Coord_Boite.txt 
ConJ1ExB7_Mask.png 
ConJ1ExB7_Coord_Blob.txt 
ConJ1ExB7_Coord_Boite.txt 
ConJ1ExB8_Mask.png 
ConJ1ExB8_Coord_Blob.txt 
ConJ1ExB8_Coord_Boite.txt 
Results_ConJ1Ex.csv 
 

Jour suivant 
 
Une fois les résultats du jour 1 sauvegardé, fermez le tableau, vous pouvez ensuite attaquer 
le Jour 2 et ainsi de suite avec le groupe expérimental et le groupe contrôle. 
 

Expérience croissance 
 
Une fois l’expérience exploration analysée faite de même avec l’expérience croissance  
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Exemple de contours pour expérience croissance 
 

 
 

Exemples de contours 
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Impossible à analyser (exemple) 
 
 

 
 
 
 
 
 
Derrière le blob, la recherche 
Retrouvez en ligne toutes les ressources et informations sur le projet de science 
participative proposé par le CNRS :  

https://www.cnrs.fr/fr/cnrsinfo/le-blob-et-la-demarche-scientifique 

Et suivez le projet sur les réseaux sociaux avec le hashtag #BlobCNRS  
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